Degraded performance connecting to kickstarter.com
Incident Report for Kickstarter
Resolved
A fix is being rolled out and we're seeing traffic return to normal.
Posted Jun 08, 2021 - 07:36 EDT
Update
Our service provider Fastly has identified the issue and are implementing a solution
Posted Jun 08, 2021 - 06:49 EDT
Identified
An upstream service provider is experiencing degraded performance
Posted Jun 08, 2021 - 06:09 EDT
This incident affected: Kickstarter.com.