All-clear! We've been monitoring the site and everything looks good. Sorry for any trouble.
Posted May 13, 2025 - 14:14 EDT
Monitoring
This issue has been resolved, and we're keeping an eye on site performance to make sure everything is working smoothly. Please stay tuned for the all-clear.
Posted May 13, 2025 - 09:27 EDT
Investigating
We're working with our payments provider to diagnose the issue. Thanks for your patience!
Posted May 13, 2025 - 08:10 EDT
This incident affected: Kickstarter.com, Payments, and Mobile.